{"action":"Upgrade flowise to 3.0.8 or later.","affected":[{"fixed":"3.0.8","introduced":"0"}],"component":"flowise","cve_ids":["CVE-2025-50538"],"ecosystem":"npm","epss":0.1404,"exploited":false,"fixed_versions":["3.0.8"],"ghsa_id":"GHSA-964p-j4gg-mhwc","id":"tcs_01M5KFEYZ035388G9QY92FDBQP","modified_at":"2026-07-08T07:59:25.876490406Z","published_at":"2025-10-03T21:47:37Z","references":["https://osv.dev/vulnerability/GHSA-964p-j4gg-mhwc","https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-964p-j4gg-mhwc","https://nvd.nist.gov/vuln/detail/CVE-2025-50538","https://github.com/FlowiseAI/Flowise/pull/4905","https://github.com/FlowiseAI/Flowise/commit/9a06a85a8ddcbaeca1342827a5fea9087a587d97","https://github.com/FlowiseAI/Flowise","https://github.com/FlowiseAI/Flowise/releases/tag/flowise%403.0.5"],"severity":{"label":"critical","score":9.3},"sources":[{"source":"osv","source_id":"GHSA-964p-j4gg-mhwc","url":"https://osv.dev/vulnerability/GHSA-964p-j4gg-mhwc"}],"summary":"Flowise is vulnerable to stored XSS via \"View Messages\" allows credential theft in FlowiseAI admin panel"}