{"action":"Upgrade apache-airflow-providers-apache-spark to 4.0.1 or later.","affected":[{"fixed":"4.0.1","introduced":"0"}],"component":"apache-airflow-providers-apache-spark","cve_ids":["CVE-2023-28710"],"ecosystem":"PyPI","epss":0.02152,"exploited":false,"fixed_versions":["4.0.1"],"ghsa_id":"GHSA-ffj9-4crc-q7wf","id":"tcs_01M5KFF5601MNVMC8S13GP24W6","modified_at":"2026-07-07T17:56:39.590415888Z","published_at":"2023-04-07T15:30:38Z","references":["https://osv.dev/vulnerability/GHSA-ffj9-4crc-q7wf","https://nvd.nist.gov/vuln/detail/CVE-2023-28710","https://github.com/apache/airflow/pull/30223","https://github.com/apache/airflow","https://lists.apache.org/thread/lb9w9114ow00h2nkn8bjm106v5x1p1d2","http://www.openwall.com/lists/oss-security/2023/04/07/3"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-ffj9-4crc-q7wf","url":"https://osv.dev/vulnerability/GHSA-ffj9-4crc-q7wf"}],"summary":"Apache Airflow Spark Provider vulnerable to improper input validation"}