{"action":"Upgrade hpack to 2.3.0 or later.","affected":[{"fixed":"2.3.0","introduced":"1.0.0"}],"component":"hpack","cve_ids":["CVE-2016-6581"],"ecosystem":"PyPI","epss":0.01877,"exploited":false,"fixed_versions":["2.3.0"],"ghsa_id":"GHSA-ffq8-576r-v26g","id":"tcs_01M5KFF6YXFXE8ZVT7W4XDCNX3","modified_at":"2024-11-30T05:39:01.605415Z","published_at":"2019-07-05T21:11:05Z","references":["https://osv.dev/vulnerability/GHSA-ffq8-576r-v26g","https://nvd.nist.gov/vuln/detail/CVE-2016-6581","https://github.com/advisories/GHSA-ffq8-576r-v26g","https://github.com/pypa/advisory-database/tree/main/vulns/hpack/PYSEC-2017-87.yaml","https://github.com/python-hyper/hpack","https://python-hyper.org/hpack/en/latest/security/CVE-2016-6581.html","https://web.archive.org/web/20200227233559/http://www.securityfocus.com/bid/92315","http://python-hyper.org/projects/hpack/en/stable/security/CVE-2016-6581.html"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-ffq8-576r-v26g","url":"https://osv.dev/vulnerability/GHSA-ffq8-576r-v26g"}],"summary":"HPACK Denial of Service vulnerability (HPACK Bomb)"}