{"action":"Upgrade mlflow to 3.11.1 or later.","affected":[{"fixed":"3.11.1","introduced":"0"}],"component":"mlflow","cve_ids":["CVE-2026-33865"],"ecosystem":"PyPI","epss":0.00218,"exploited":false,"fixed_versions":["3.11.1"],"ghsa_id":"GHSA-fh64-r2vc-xvhr","id":"tcs_01M5KFFC6QGBXSNNQDRVTJ2RXX","modified_at":"2026-09-10T03:50:44.231753603Z","published_at":"2026-04-07T15:30:50Z","references":["https://osv.dev/vulnerability/GHSA-fh64-r2vc-xvhr","https://nvd.nist.gov/vuln/detail/CVE-2026-33865","https://github.com/mlflow/mlflow/pull/21435","https://github.com/mlflow/mlflow/commit/aca4dd0ec88a12f7655155c224371280e9b45dda","https://afine.com/blogs/attacking-mlflow-how-ml-artifacts-become-attack-vectors","https://cert.pl/en/posts/2026/04/CVE-2026-33865","https://github.com/mlflow/mlflow","https://github.com/pypa/advisory-database/tree/main/vulns/mlflow/PYSEC-2026-93.yaml"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-fh64-r2vc-xvhr","url":"https://osv.dev/vulnerability/GHSA-fh64-r2vc-xvhr"}],"summary":"MLflow is vulnerable to Stored Cross-Site Scripting (XSS) caused by unsafe parsing of YAML-based MLmodel artifacts in its web interface"}