{"action":"Upgrade langchain to 0.0.247 or later.","affected":[{"fixed":"0.0.247","introduced":"0"}],"component":"langchain","cve_ids":["CVE-2023-38860"],"ecosystem":"PyPI","epss":0.01417,"exploited":false,"fixed_versions":["0.0.247"],"ghsa_id":"GHSA-fj32-q626-pjjc","id":"tcs_01M5KFFEVJ9NBASZR9RCAADFR1","modified_at":"2024-09-27T18:01:17.289232Z","published_at":"2023-08-15T18:31:32Z","references":["https://osv.dev/vulnerability/GHSA-fj32-q626-pjjc","https://nvd.nist.gov/vuln/detail/CVE-2023-38860","https://github.com/hwchase17/langchain/issues/7641","https://github.com/langchain-ai/langchain/issues/7641","https://github.com/langchain-ai/langchain/pull/8092","https://github.com/langchain-ai/langchain/pull/8425","https://github.com/langchain-ai/langchain/commit/d353d668e4b0514122a443cef91de7f76fea4245","https://github.com/langchain-ai/langchain/commit/fab24457bcf8ede882abd11419769c92bc4e7751","https://github.com/hwchase17/langchain","https://github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2023-145.yaml"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-fj32-q626-pjjc","url":"https://osv.dev/vulnerability/GHSA-fj32-q626-pjjc"}],"summary":"LangChain vulnerable to arbitrary code execution"}