{"action":"Upgrade charset to 1.0.1 or later.","affected":[{"fixed":"1.0.1","introduced":"0"}],"component":"charset","cve_ids":["CVE-2017-16098"],"ecosystem":"npm","epss":0.01631,"exploited":false,"fixed_versions":["1.0.1"],"ghsa_id":"GHSA-9cp3-fh5x-xfcj","id":"tcs_01M5KFFHVAP8ZK1754G5SK2VGH","modified_at":"2023-11-08T03:59:04.732980Z","published_at":"2018-08-09T20:55:46Z","references":["https://osv.dev/vulnerability/GHSA-9cp3-fh5x-xfcj","https://nvd.nist.gov/vuln/detail/CVE-2017-16098","https://github.com/node-modules/charset/issues/10","https://github.com/node-modules/charset/pull/11","https://github.com/node-modules/charset/commit/effda0c48c51b47a47f4cad7db0c51ee7407cc1b","https://github.com/node-modules/charset"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-9cp3-fh5x-xfcj","url":"https://osv.dev/vulnerability/GHSA-9cp3-fh5x-xfcj"}],"summary":"Regular Expression Denial of Service in charset"}