{"action":"Upgrade flask-appbuilder to 4.2.1 or later.","affected":[{"fixed":"4.2.1","introduced":"4.1.4"}],"component":"flask-appbuilder","cve_ids":["CVE-2024-27083"],"ecosystem":"PyPI","epss":0.00567,"exploited":false,"fixed_versions":["4.2.1"],"ghsa_id":"GHSA-fqxj-46wg-9v84","id":"tcs_01M5KFFZFBAYSMK1STZYK4BXSZ","modified_at":"2026-09-10T03:50:06.227675631Z","published_at":"2024-02-28T18:37:01Z","references":["https://osv.dev/vulnerability/GHSA-fqxj-46wg-9v84","https://github.com/dpgaspar/Flask-AppBuilder/security/advisories/GHSA-fqxj-46wg-9v84","https://nvd.nist.gov/vuln/detail/CVE-2024-27083","https://github.com/dpgaspar/Flask-AppBuilder/commit/3d17741886e4b3c384d0570de69689e4117aa812","https://github.com/dpgaspar/Flask-AppBuilder"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"GHSA-fqxj-46wg-9v84","url":"https://osv.dev/vulnerability/GHSA-fqxj-46wg-9v84"}],"summary":"Flask-AppBuilder's OAuth login page subject to Cross Site Scripting (XSS)"}