{"action":"Upgrade goauthentik.io to 2023.8.7 or later.","affected":[{"fixed":"2023.10.7","introduced":"2023.10.0"},{"fixed":"2023.8.7","introduced":"0"}],"component":"goauthentik.io","cve_ids":["CVE-2024-23647"],"ecosystem":"Go","epss":0.00549,"exploited":false,"fixed_versions":["2023.10.7","2023.8.7"],"ghsa_id":"GHSA-mrx3-gxjx-hjqj","id":"tcs_01M5KFGE0W632GN97HVSADAY0V","modified_at":"2026-09-10T03:50:04.988243764Z","published_at":"2024-01-29T22:30:54Z","references":["https://osv.dev/vulnerability/GHSA-mrx3-gxjx-hjqj","https://github.com/goauthentik/authentik/security/advisories/GHSA-mrx3-gxjx-hjqj","https://nvd.nist.gov/vuln/detail/CVE-2024-23647","https://github.com/goauthentik/authentik/commit/38e04ae12720e5d81b4f7ac77997eb8d1275d31a","https://github.com/goauthentik/authentik"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-mrx3-gxjx-hjqj","url":"https://osv.dev/vulnerability/GHSA-mrx3-gxjx-hjqj"}],"summary":"Authentik vulnerable to PKCE downgrade attack"}