{"action":"Upgrade simple-git to 3.15.0 or later.","affected":[{"fixed":"3.15.0","introduced":"0"}],"component":"simple-git","cve_ids":["CVE-2022-25912"],"ecosystem":"npm","epss":0.03077,"exploited":false,"fixed_versions":["3.15.0"],"ghsa_id":"GHSA-9p95-fxvg-qgq2","id":"tcs_01M5KFGF69M3Y021TZN5C4GAVX","modified_at":"2023-11-08T04:08:51.887503Z","published_at":"2022-12-06T06:30:17Z","references":["https://osv.dev/vulnerability/GHSA-9p95-fxvg-qgq2","https://nvd.nist.gov/vuln/detail/CVE-2022-25912","https://github.com/steveukx/git-js/commit/774648049eb3e628379e292ea172dccaba610504","https://github.com/steveukx/git-js","https://github.com/steveukx/git-js/blob/main/docs/PLUGIN-UNSAFE-ACTIONS.md%23overriding-allowed-protocols","https://github.com/steveukx/git-js/releases/tag/simple-git%403.15.0","https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-3153532","https://security.snyk.io/vuln/SNYK-JS-SIMPLEGIT-3112221"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"GHSA-9p95-fxvg-qgq2","url":"https://osv.dev/vulnerability/GHSA-9p95-fxvg-qgq2"}],"summary":"simple-git vulnerable to Remote Code Execution when enabling the ext transport protocol"}