{"action":"Upgrade glances to 4.5.4 or later.","affected":[{"fixed":"4.5.4","introduced":"0"}],"component":"glances","cve_ids":["CVE-2026-35587"],"ecosystem":"PyPI","epss":0.00396,"exploited":false,"fixed_versions":["4.5.4"],"ghsa_id":"GHSA-g5pq-48mj-jvw8","id":"tcs_01M5KFGWY3FYF3MSR06HYF53VJ","modified_at":"2026-07-13T07:26:15.785014292Z","published_at":"2026-04-21T15:17:52Z","references":["https://osv.dev/vulnerability/GHSA-g5pq-48mj-jvw8","https://github.com/nicolargo/glances/security/advisories/GHSA-g5pq-48mj-jvw8","https://nvd.nist.gov/vuln/detail/CVE-2026-35587","https://github.com/nicolargo/glances/commit/d6808be66728956477cc4b544bab1acd71ac65fb","https://github.com/nicolargo/glances","https://github.com/nicolargo/glances/releases/tag/v4.5.4"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-g5pq-48mj-jvw8","url":"https://osv.dev/vulnerability/GHSA-g5pq-48mj-jvw8"}],"summary":"Glances has SSRF in IP Plugin via public_api leading to credential leakage"}