{"action":"Upgrade tui-grid to 4.21.3 or later.","affected":[{"fixed":"4.21.3","introduced":"0"}],"component":"tui-grid","cve_ids":["CVE-2022-23458"],"ecosystem":"npm","epss":0.00667,"exploited":false,"fixed_versions":["4.21.3"],"ghsa_id":"GHSA-9rwj-9j2h-fhvm","id":"tcs_01M5KFGY2M79J1Y1FCE2B66QDX","modified_at":"2023-11-08T04:08:18.309360Z","published_at":"2022-09-23T00:00:29Z","references":["https://osv.dev/vulnerability/GHSA-9rwj-9j2h-fhvm","https://nvd.nist.gov/vuln/detail/CVE-2022-23458","https://github.com/nhn/tui.grid/commit/e9db5968675ae113c07efc091cce210f2b26854f","https://github.com/nhn/tui.grid","https://securitylab.github.com/advisories/GHSL-2022-029_nhn_tui_grid"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-9rwj-9j2h-fhvm","url":"https://osv.dev/vulnerability/GHSA-9rwj-9j2h-fhvm"}],"summary":"Toast UI Grid vulnerable to Cross-site Scripting"}