{"action":"Upgrade pgadmin4 to 9.2 or later.","affected":[{"fixed":"9.2","introduced":"0"}],"component":"pgadmin4","cve_ids":["CVE-2025-2945"],"ecosystem":"PyPI","epss":0.563,"exploited":false,"fixed_versions":["9.2"],"ghsa_id":"GHSA-g73c-fw68-pwx3","id":"tcs_01M5KFH0R0BQEC2P6948ZS1QN0","modified_at":"2026-06-29T12:26:49.916499139Z","published_at":"2025-04-03T15:31:13Z","references":["https://osv.dev/vulnerability/GHSA-g73c-fw68-pwx3","https://nvd.nist.gov/vuln/detail/CVE-2025-2945","https://github.com/pgadmin-org/pgadmin4/issues/8603","https://github.com/pgadmin-org/pgadmin4/commit/75be0bc22d3d8d7620711835db817bd7c021007c","https://github.com/pgadmin-org/pgadmin4"],"severity":{"label":"critical","score":9.9},"sources":[{"source":"osv","source_id":"GHSA-g73c-fw68-pwx3","url":"https://osv.dev/vulnerability/GHSA-g73c-fw68-pwx3"}],"summary":"pgAdmin 4 Vulnerable to Remote Code Execution"}