{"action":"Upgrade github.com/argoproj/argo-cd to 2.3.6 or later.","affected":[{"fixed":"2.3.6","introduced":"2.3.0"},{"fixed":"2.4.5","introduced":"2.4.0"}],"component":"github.com/argoproj/argo-cd","cve_ids":["CVE-2022-31102"],"ecosystem":"Go","epss":0.00629,"exploited":false,"fixed_versions":["2.3.6","2.4.5"],"ghsa_id":"GHSA-pmjg-52h9-72qv","id":"tcs_01M5KFHK3WHYF95TWZZ9D4PSR2","modified_at":"2024-08-21T15:41:45.788815Z","published_at":"2022-07-12T22:11:16Z","references":["https://osv.dev/vulnerability/GHSA-pmjg-52h9-72qv","https://github.com/argoproj/argo-cd/security/advisories/GHSA-pmjg-52h9-72qv","https://nvd.nist.gov/vuln/detail/CVE-2022-31102","https://github.com/argoproj/argo-cd/commit/3800a1e49d1d5a00a6692fee83396a37a6abe89a","https://github.com/argoproj/argo-cd/commit/8d5119b1e3038a2c1d8b651cb242525e9e734c4c","https://github.com/argoproj/argo-cd","https://github.com/argoproj/argo-cd/releases/tag/v2.3.6","https://github.com/argoproj/argo-cd/releases/tag/v2.4.5"],"severity":{"label":"low","score":2.6},"sources":[{"source":"osv","source_id":"GHSA-pmjg-52h9-72qv","url":"https://osv.dev/vulnerability/GHSA-pmjg-52h9-72qv"}],"summary":"Argo CD SSO users vulnerable to Cross-site Scripting"}