{"action":"Upgrade next to 15.5.16 or later.","affected":[{"fixed":"15.5.16","introduced":"13.4.13"},{"fixed":"16.2.5","introduced":"16.0.0"}],"component":"next","cve_ids":["CVE-2026-44578"],"ecosystem":"npm","epss":0.35539,"exploited":false,"fixed_versions":["15.5.16","16.2.5"],"ghsa_id":"GHSA-c4j6-fc7j-m34r","id":"tcs_01M5KFHQM8XAB7QWNGR6K6W0A0","modified_at":"2026-09-10T03:50:46.499274814Z","published_at":"2026-05-11T15:55:15Z","references":["https://osv.dev/vulnerability/GHSA-c4j6-fc7j-m34r","https://github.com/vercel/next.js/security/advisories/GHSA-c4j6-fc7j-m34r","https://nvd.nist.gov/vuln/detail/CVE-2026-44578","https://github.com/vercel/next.js","https://github.com/vercel/next.js/releases/tag/v15.5.16","https://github.com/vercel/next.js/releases/tag/v16.2.5"],"severity":{"label":"high","score":8.6},"sources":[{"source":"osv","source_id":"GHSA-c4j6-fc7j-m34r","url":"https://osv.dev/vulnerability/GHSA-c4j6-fc7j-m34r"}],"summary":"Next.js vulnerable to server-side request forgery in applications using WebSocket upgrades"}