{"action":"Upgrade @vitejs/plugin-rsc to 0.5.7 or later.","affected":[{"fixed":"0.5.7","introduced":"0"}],"component":"@vitejs/plugin-rsc","cve_ids":[],"ecosystem":"npm","exploited":false,"fixed_versions":["0.5.7"],"ghsa_id":"GHSA-c6m7-q6pr-c64r","id":"tcs_01M5KFHY360Q01H83PM84KCQSR","modified_at":"2025-12-12T16:54:17.233749Z","published_at":"2025-12-12T16:41:58Z","references":["https://osv.dev/vulnerability/GHSA-c6m7-q6pr-c64r","https://github.com/facebook/react/security/advisories/GHSA-925w-6v3x-g4j4","https://github.com/vitejs/vite-plugin-react/security/advisories/GHSA-c6m7-q6pr-c64r","https://github.com/vitejs/vite-plugin-react"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-c6m7-q6pr-c64r","url":"https://osv.dev/vulnerability/GHSA-c6m7-q6pr-c64r"}],"summary":"Vite Plugin React has a Source Code Exposure Vulnerability in React Server Components"}