{"action":"Upgrade @angular/core to 10.2.5 or later.","affected":[{"fixed":"11.0.5","introduced":"11.0.0"},{"fixed":"11.1.0-next.3","introduced":"11.1.0-next.0"},{"fixed":"10.2.5","introduced":"0"}],"component":"@angular/core","cve_ids":["CVE-2021-4231"],"ecosystem":"npm","epss":0.01181,"exploited":false,"fixed_versions":["11.0.5","11.1.0-next.3","10.2.5"],"ghsa_id":"GHSA-c75v-2vq8-878f","id":"tcs_01M5KFJ147QDAN0SXW7XB45WV9","modified_at":"2026-09-10T03:49:21.863578485Z","published_at":"2022-05-27T00:01:08Z","references":["https://osv.dev/vulnerability/GHSA-c75v-2vq8-878f","https://nvd.nist.gov/vuln/detail/CVE-2021-4231","https://github.com/angular/angular/issues/40136","https://github.com/angular/angular/commit/0aa220bc0000fc4d1651ec388975bbf5baa1da36","https://github.com/angular/angular/commit/47d9b6d72dab9d60c96bc1c3604219f6385649ea","https://github.com/angular/angular/commit/ba8da742e3b243e8f43d4c63aa842b44e14f2b09","https://github.com/angular/angular","https://security.snyk.io/vuln/SNYK-JS-ANGULARCORE-1070902","https://vuldb.com/?id.181356"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-c75v-2vq8-878f","url":"https://osv.dev/vulnerability/GHSA-c75v-2vq8-878f"}],"summary":"Angular vulnerable to Cross-site Scripting"}