{"action":"Upgrade werkzeug to 0.15.3 or later.","affected":[{"fixed":"0.15.3","introduced":"0"}],"component":"werkzeug","cve_ids":["CVE-2019-14806"],"ecosystem":"PyPI","epss":0.01909,"exploited":false,"fixed_versions":["0.15.3"],"ghsa_id":"GHSA-gq9m-qvpx-68hc","id":"tcs_01M5KFJ46AVF4H8E6E0QDF176F","modified_at":"2024-11-19T18:22:43.515928Z","published_at":"2019-08-21T16:15:24Z","references":["https://osv.dev/vulnerability/GHSA-gq9m-qvpx-68hc","https://nvd.nist.gov/vuln/detail/CVE-2019-14806","https://github.com/pallets/werkzeug/commit/00bc43b1672e662e5e3b8cecd79e67fc968fa246","https://github.com/pallets/werkzeug","https://github.com/pallets/werkzeug/blob/7fef41b120327d3912fbe12fb64f1951496fcf3e/src/werkzeug/debug/__init__.py#L168","https://github.com/pypa/advisory-database/tree/main/vulns/werkzeug/PYSEC-2019-140.yaml","https://palletsprojects.com/blog/werkzeug-0-15-3-released","http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00034.html","http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00047.html"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-gq9m-qvpx-68hc","url":"https://osv.dev/vulnerability/GHSA-gq9m-qvpx-68hc"}],"summary":"Pallets Werkzeug Insufficient Entropy"}