{"action":"Upgrade ansible to 2.6.18 or later.","affected":[{"fixed":"2.6.18","introduced":"0"},{"fixed":"2.7.12","introduced":"2.7.0a1"},{"fixed":"2.8.2","introduced":"2.8.0a1"}],"component":"ansible","cve_ids":["CVE-2019-10156"],"ecosystem":"PyPI","epss":0.01774,"exploited":false,"fixed_versions":["2.6.18","2.7.12","2.8.2"],"ghsa_id":"GHSA-grgm-pph5-j5h7","id":"tcs_01M5KFJ69EMGZ0PBKK2RK9BZRS","modified_at":"2024-09-04T21:02:06.281445Z","published_at":"2019-07-31T04:22:49Z","references":["https://osv.dev/vulnerability/GHSA-grgm-pph5-j5h7","https://nvd.nist.gov/vuln/detail/CVE-2019-10156","https://github.com/ansible/ansible/pull/57188","https://github.com/ansible/ansible/commit/04e94274fb92e116e9082cc9b86b1fd05c836922","https://github.com/ansible/ansible/commit/3ff6505e8ff0e4655bab008886983476ef903375","https://github.com/ansible/ansible/commit/a11c3edfa41e7e4a4db323cdabfc2eae1b61da2a","https://access.redhat.com/errata/RHSA-2019:3744","https://access.redhat.com/errata/RHSA-2019:3789","https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10156","https://github.com/advisories/GHSA-grgm-pph5-j5h7","https://github.com/ansible/ansible","https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2019-2.yaml","https://lists.debian.org/debian-lts-announce/2019/09/msg00016.html","https://lists.debian.org/debian-lts-announce/2021/01/msg00023.html","https://www.debian.org/security/2021/dsa-4950"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-grgm-pph5-j5h7","url":"https://osv.dev/vulnerability/GHSA-grgm-pph5-j5h7"}],"summary":"Exposure of Sensitive Information to an Unauthorized Actor in ansible"}