{"action":"Upgrade tensorflow-cpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29607"],"ecosystem":"PyPI","epss":0.00234,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-gv26-jpj9-c8gq","id":"tcs_01M5KFJ8B9GC0801509PGFZV8M","modified_at":"2026-07-08T06:28:33.528793207Z","published_at":"2022-03-18T17:52:25Z","references":["https://osv.dev/vulnerability/GHSA-gv26-jpj9-c8gq","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-gv26-jpj9-c8gq","https://nvd.nist.gov/vuln/detail/CVE-2021-29607","https://github.com/tensorflow/tensorflow/commit/ba6822bd7b7324ba201a28b2f278c29a98edbef2","https://github.com/tensorflow/tensorflow/commit/f6fde895ef9c77d848061c0517f19d0ec2682f3a","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-535.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-733.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-244.yaml"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-gv26-jpj9-c8gq#PyPI/tensorflow-cpu","url":"https://osv.dev/vulnerability/GHSA-gv26-jpj9-c8gq"}],"summary":"Incomplete validation in `SparseSparseMinimum`"}