{"action":"Upgrade web2py to 2.14.6 or later.","affected":[{"fixed":"2.14.6","introduced":"0"}],"component":"web2py","cve_ids":["CVE-2016-10321"],"ecosystem":"PyPI","epss":0.02608,"exploited":false,"fixed_versions":["2.14.6"],"ghsa_id":"GHSA-gv85-wgxc-vc56","id":"tcs_01M5KFJ9BQE8GMR24QGH1DMYDK","modified_at":"2026-06-29T12:26:22.739408853Z","published_at":"2022-05-14T00:57:47Z","references":["https://osv.dev/vulnerability/GHSA-gv85-wgxc-vc56","https://nvd.nist.gov/vuln/detail/CVE-2016-10321","https://github.com/web2py/web2py/issues/1585#issuecomment-284317919","https://github.com/web2py/web2py/commit/944d8bd8f3c5cf8ae296fc03d149056c65358426","https://github.com/web2py/web2py","https://usn.ubuntu.com/4030-1"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-gv85-wgxc-vc56","url":"https://osv.dev/vulnerability/GHSA-gv85-wgxc-vc56"}],"summary":"web2py is vulnerable to password brute-force attack"}