{"action":"Upgrade djangorestframework to 3.15.2 or later.","affected":[{"fixed":"3.15.2","introduced":"0"}],"component":"djangorestframework","cve_ids":["CVE-2024-21520"],"ecosystem":"PyPI","epss":0.01133,"exploited":false,"fixed_versions":["3.15.2"],"ghsa_id":"GHSA-gw84-84pc-xp82","id":"tcs_01M5KFJC6WGQGE3MSYRA5CJGND","modified_at":"2026-07-07T17:57:11.525258427Z","published_at":"2024-06-26T06:30:29Z","references":["https://osv.dev/vulnerability/GHSA-gw84-84pc-xp82","https://nvd.nist.gov/vuln/detail/CVE-2024-21520","https://github.com/encode/django-rest-framework/pull/9435","https://github.com/encode/django-rest-framework/commit/3b41f0124194430da957b119712978fa2266b642","https://github.com/encode/django-rest-framework","https://github.com/encode/django-rest-framework/compare/3.15.1...3.15.2","https://security.snyk.io/vuln/SNYK-PYTHON-DJANGORESTFRAMEWORK-7252137"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-gw84-84pc-xp82","url":"https://osv.dev/vulnerability/GHSA-gw84-84pc-xp82"}],"summary":"Cross-site Scripting in djangorestframework"}