{"action":"Upgrade ansible to 2.7.16 or later.","affected":[{"fixed":"2.7.16","introduced":"0"},{"fixed":"2.8.8","introduced":"2.8.0a1"},{"fixed":"2.9.3","introduced":"2.9.0a1"}],"component":"ansible","cve_ids":["CVE-2019-14904"],"ecosystem":"PyPI","epss":0.00421,"exploited":false,"fixed_versions":["2.7.16","2.8.8","2.9.3"],"ghsa_id":"GHSA-gwr8-5j83-483c","id":"tcs_01M5KFJEHP84N9F1R7BAKZAP2E","modified_at":"2024-09-06T20:21:41.972450Z","published_at":"2021-04-20T16:44:22Z","references":["https://osv.dev/vulnerability/GHSA-gwr8-5j83-483c","https://nvd.nist.gov/vuln/detail/CVE-2019-14904","https://github.com/ansible/ansible/pull/65686","https://github.com/ansible/ansible/commit/589a415f887b6f2bb65cd07fe6b2e9d0a8156b69","https://github.com/ansible/ansible/commit/6a86650109b8654f5898369e45d3857624edf907","https://github.com/ansible/ansible/commit/a1b0f72c98b4b2afaab8aafa255e82c2075049c8","https://bugzilla.redhat.com/show_bug.cgi?id=1776944","https://github.com/advisories/GHSA-gwr8-5j83-483c","https://github.com/ansible/ansible","https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-161.yaml","https://lists.debian.org/debian-lts-announce/2021/01/msg00023.html","https://www.debian.org/security/2021/dsa-4950"],"severity":{"label":"high","score":7.3},"sources":[{"source":"osv","source_id":"GHSA-gwr8-5j83-483c","url":"https://osv.dev/vulnerability/GHSA-gwr8-5j83-483c"}],"summary":"OS Command Injection and Improper Input Validation in ansible"}