{"action":"Upgrade uwsgi to 2.0.17 or later.","affected":[{"fixed":"2.0.17","introduced":"0"}],"component":"uwsgi","cve_ids":["CVE-2018-7490"],"ecosystem":"PyPI","epss":0.69423,"exploited":false,"fixed_versions":["2.0.17"],"ghsa_id":"GHSA-h2vm-c85r-5vh5","id":"tcs_01M5KFJJB0S551PQ519GRFXMF1","modified_at":"2024-11-18T23:02:33.020001Z","published_at":"2022-05-14T03:35:52Z","references":["https://osv.dev/vulnerability/GHSA-h2vm-c85r-5vh5","https://nvd.nist.gov/vuln/detail/CVE-2018-7490","https://github.com/unbit/uwsgi/commit/0a480f435ea6feb63deb410ad2bf376ed3f05f8a","https://github.com/pypa/advisory-database/tree/main/vulns/uwsgi/PYSEC-2018-78.yaml","https://github.com/unbit/uwsgi","https://uwsgi-docs.readthedocs.io/en/latest/Changelog-2.0.17.html","https://www.debian.org/security/2018/dsa-4142","https://www.exploit-db.com/exploits/44223"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-h2vm-c85r-5vh5","url":"https://osv.dev/vulnerability/GHSA-h2vm-c85r-5vh5"}],"summary":"uWSGI Directory Traversal vulnerability"}