{"action":"Upgrade github.com/go-acme/lego/v4 to 4.25.2 or later.","affected":[{"fixed":"4.25.2","introduced":"0"}],"component":"github.com/go-acme/lego/v4","cve_ids":["CVE-2025-54799"],"ecosystem":"Go","epss":0.00238,"exploited":false,"fixed_versions":["4.25.2"],"ghsa_id":"GHSA-q82r-2j7m-9rv4","id":"tcs_01M5KFJMM87K62ZKVGH32BBN8G","modified_at":"2026-09-10T03:50:27.302884949Z","published_at":"2025-08-06T17:08:52Z","references":["https://osv.dev/vulnerability/GHSA-q82r-2j7m-9rv4","https://github.com/go-acme/lego/security/advisories/GHSA-q82r-2j7m-9rv4","https://nvd.nist.gov/vuln/detail/CVE-2025-54799","https://github.com/go-acme/lego/commit/238454b5f74f3cfcbb244ff0d0dc914a4ad44b96","https://github.com/go-acme/lego"],"severity":{"label":"low","score":2.3},"sources":[{"source":"osv","source_id":"GHSA-q82r-2j7m-9rv4#Go/github.com/go-acme/lego/v4","url":"https://osv.dev/vulnerability/GHSA-q82r-2j7m-9rv4"},{"source":"nvd","source_id":"CVE-2025-54799","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-54799"}],"summary":"github.com/go-acme/lego/v4/acme/api does not enforce HTTPS"}