{"action":"Upgrade k8s.io/kubernetes to 1.24.15 or later.","affected":[{"fixed":"1.27.3","introduced":"1.27.0"},{"fixed":"1.26.6","introduced":"1.26.0"},{"fixed":"1.25.11","introduced":"1.25.0"},{"fixed":"1.24.15","introduced":"0"}],"component":"k8s.io/kubernetes","cve_ids":["CVE-2023-2727"],"ecosystem":"Go","epss":0.01134,"exploited":false,"fixed_versions":["1.27.3","1.26.6","1.25.11","1.24.15"],"ghsa_id":"GHSA-qc2g-gmh6-95p4","id":"tcs_01M5KFJV509ZQ7NVZR1W3EC4GF","modified_at":"2026-09-10T03:50:02.663366084Z","published_at":"2023-07-03T21:30:57Z","references":["https://osv.dev/vulnerability/GHSA-qc2g-gmh6-95p4","https://nvd.nist.gov/vuln/detail/CVE-2023-2727","https://github.com/kubernetes/kubernetes/issues/118640","https://github.com/kubernetes/kubernetes/pull/118356","https://github.com/kubernetes/kubernetes/pull/118471","https://github.com/kubernetes/kubernetes/pull/118473","https://github.com/kubernetes/kubernetes/pull/118474","https://github.com/kubernetes/kubernetes/pull/118512","https://github.com/kubernetes/kubernetes","https://groups.google.com/g/kubernetes-security-announce/c/vPWYJ_L84m8","https://security.netapp.com/advisory/ntap-20230803-0004","http://www.openwall.com/lists/oss-security/2023/07/06/2"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-qc2g-gmh6-95p4","url":"https://osv.dev/vulnerability/GHSA-qc2g-gmh6-95p4"}],"summary":"kube-apiserver vulnerable to policy bypass"}