{"action":"Upgrade langchain-core to 0.1.30 or later.","affected":[{"fixed":"0.1.30","introduced":"0"}],"component":"langchain-core","cve_ids":["CVE-2024-28088"],"ecosystem":"PyPI","epss":0.01726,"exploited":false,"fixed_versions":["0.1.30"],"ghsa_id":"GHSA-h59x-p739-982c","id":"tcs_01M5KFJVJ7NJ4KEP59Z19K7KBR","modified_at":"2024-12-03T05:59:19.205896Z","published_at":"2024-03-04T00:30:53Z","references":["https://osv.dev/vulnerability/GHSA-h59x-p739-982c","https://nvd.nist.gov/vuln/detail/CVE-2024-28088","https://github.com/langchain-ai/langchain/pull/18600","https://github.com/langchain-ai/langchain/commit/e1924b3e93d513ca950c72f8e80e1c133749fba5","https://github.com/PinkDraconian/PoC-Langchain-RCE/blob/main/README.md","https://github.com/langchain-ai/langchain","https://github.com/langchain-ai/langchain/blob/f96dd57501131840b713ed7c2e86cbf1ddc2761f/libs/core/langchain_core/utils/loading.py","https://github.com/pypa/advisory-database/tree/main/vulns/langchain-core/PYSEC-2024-45.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2024-43.yaml"],"severity":{"label":"low"},"sources":[{"source":"osv","source_id":"GHSA-h59x-p739-982c#PyPI/langchain-core","url":"https://osv.dev/vulnerability/GHSA-h59x-p739-982c"}],"summary":"LangChain directory traversal vulnerability"}