{"action":"Upgrade tensorflow-gpu to 2.6.4 or later.","affected":[{"fixed":"2.6.4","introduced":"0"},{"fixed":"2.7.2","introduced":"2.7.0"},{"fixed":"2.8.1","introduced":"2.8.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-29194"],"ecosystem":"PyPI","epss":0.00333,"exploited":false,"fixed_versions":["2.6.4","2.7.2","2.8.1"],"ghsa_id":"GHSA-h5g4-ppwx-48q2","id":"tcs_01M5KFJWCTQA8GG4XGDB1R2S8F","modified_at":"2026-07-13T16:43:02.599989243Z","published_at":"2022-05-24T22:06:50Z","references":["https://osv.dev/vulnerability/GHSA-h5g4-ppwx-48q2","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-h5g4-ppwx-48q2","https://nvd.nist.gov/vuln/detail/CVE-2022-29194","https://github.com/tensorflow/tensorflow/commit/cff267650c6a1b266e4b4500f69fbc49cdd773c5","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/blob/f3b9bf4c3c0597563b289c0512e98d4ce81f886e/tensorflow/core/kernels/session_ops.cc#L128-L144","https://github.com/tensorflow/tensorflow/releases/tag/v2.6.4","https://github.com/tensorflow/tensorflow/releases/tag/v2.7.2","https://github.com/tensorflow/tensorflow/releases/tag/v2.8.1","https://github.com/tensorflow/tensorflow/releases/tag/v2.9.0"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"GHSA-h5g4-ppwx-48q2#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-h5g4-ppwx-48q2"}],"summary":"Missing validation causes denial of service via `DeleteSessionTensor`"}