{"action":"Upgrade langchain-community to 0.0.28 or later.","affected":[{"fixed":"0.0.28","introduced":"0"}],"component":"langchain-community","cve_ids":["CVE-2025-2828"],"ecosystem":"PyPI","epss":0.21019,"exploited":false,"fixed_versions":["0.0.28"],"ghsa_id":"GHSA-h5gc-rm8j-5gpr","id":"tcs_01M5KFJWHS4G3XDNYRCH1J4CA4","modified_at":"2025-07-17T22:23:18.384887Z","published_at":"2025-06-23T21:31:56Z","references":["https://osv.dev/vulnerability/GHSA-h5gc-rm8j-5gpr","https://nvd.nist.gov/vuln/detail/CVE-2025-2828","https://github.com/langchain-ai/langchain/commit/e188d4ecb085d4561a0be3c583d26aa9c2c3283f","https://github.com/langchain-ai/langchain-community","https://github.com/pypa/advisory-database/tree/main/vulns/langchain-community/PYSEC-2025-70.yaml","https://huntr.com/bounties/8f771040-7f34-420a-b96b-5b93d4a99afc"],"severity":{"label":"high","score":8.4},"sources":[{"source":"osv","source_id":"GHSA-h5gc-rm8j-5gpr","url":"https://osv.dev/vulnerability/GHSA-h5gc-rm8j-5gpr"}],"summary":"LangChain Community SSRF vulnerability exists in RequestsToolkit component"}