{"action":"Upgrade apache-airflow to 2.4.2rc1 or later.","affected":[{"fixed":"2.4.2rc1","introduced":"0"}],"component":"apache-airflow","cve_ids":["CVE-2022-43982"],"ecosystem":"PyPI","epss":0.01759,"exploited":false,"fixed_versions":["2.4.2rc1"],"ghsa_id":"GHSA-h63r-9xxf-f2c7","id":"tcs_01M5KFJY4DR8JV1TF06FT3CHSM","modified_at":"2025-05-02T22:03:35.214533Z","published_at":"2022-11-02T19:00:33Z","references":["https://osv.dev/vulnerability/GHSA-h63r-9xxf-f2c7","https://nvd.nist.gov/vuln/detail/CVE-2022-43982","https://github.com/apache/airflow/pull/27143","https://github.com/apache/airflow/commit/9fb4814d29d934cef3b02fb3b2547f9fb76aaa97","https://github.com/apache/airflow","https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2022-42970.yaml","https://lists.apache.org/thread/vqnvdrfsw9z7v7c46qh3psjgr7wy959l"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-h63r-9xxf-f2c7","url":"https://osv.dev/vulnerability/GHSA-h63r-9xxf-f2c7"}],"summary":"Apache Airflow Cross-site Scripting vulnerability"}