{"action":"Upgrade plone-rest to 2.0.1 or later.","affected":[{"fixed":"2.0.1","introduced":"2.0.0a1"},{"fixed":"3.0.1","introduced":"3.0.0"}],"component":"plone-rest","cve_ids":["CVE-2023-42457"],"ecosystem":"PyPI","epss":0.01013,"exploited":false,"fixed_versions":["2.0.1","3.0.1"],"ghsa_id":"GHSA-h6rp-mprm-xgcq","id":"tcs_01M5KFK2ES38V1FX8BJREEWSEH","modified_at":"2025-02-13T19:36:59.155073Z","published_at":"2023-09-21T17:06:37Z","references":["https://osv.dev/vulnerability/GHSA-h6rp-mprm-xgcq","https://github.com/plone/plone.rest/security/advisories/GHSA-h6rp-mprm-xgcq","https://nvd.nist.gov/vuln/detail/CVE-2023-42457","https://github.com/plone/plone.rest/commit/43b4a7e86206e237e1de5ca3817ed071575882f7","https://github.com/plone/plone.rest/commit/77846a9842889b24f35e8bedc2e9d461388d3302","https://github.com/plone/plone.rest","https://github.com/pypa/advisory-database/tree/main/vulns/plone-rest/PYSEC-2023-178.yaml","http://www.openwall.com/lists/oss-security/2023/09/22/2"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-h6rp-mprm-xgcq","url":"https://osv.dev/vulnerability/GHSA-h6rp-mprm-xgcq"}],"summary":"plone.rest vulnerable to Denial of Service when ++api++ is used many times"}