{"action":"Upgrade parse-server to 8.6.15 or later.","affected":[{"fixed":"8.6.15","introduced":"0"},{"fixed":"9.5.2-alpha.2","introduced":"9.0.0"}],"component":"parse-server","cve_ids":["CVE-2026-30946"],"ecosystem":"npm","epss":0.00572,"exploited":false,"fixed_versions":["8.6.15","9.5.2-alpha.2"],"ghsa_id":"GHSA-cmj3-wx7h-ffvg","id":"tcs_01M5KFK519G8WDMXT0A08ZHN3M","modified_at":"2026-03-16T20:46:27.523939Z","published_at":"2026-03-11T00:16:48Z","references":["https://osv.dev/vulnerability/GHSA-cmj3-wx7h-ffvg","https://github.com/parse-community/parse-server/security/advisories/GHSA-cmj3-wx7h-ffvg","https://nvd.nist.gov/vuln/detail/CVE-2026-30946","https://github.com/parse-community/parse-server","https://github.com/parse-community/parse-server/releases/tag/8.6.15","https://github.com/parse-community/parse-server/releases/tag/9.5.2-alpha.2"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-cmj3-wx7h-ffvg","url":"https://osv.dev/vulnerability/GHSA-cmj3-wx7h-ffvg"}],"summary":"Parse Server affected by denial-of-service via unbounded query complexity in REST and GraphQL API"}