{"action":"Upgrade octoprint to 1.8.0 or later.","affected":[{"fixed":"1.8.0","introduced":"0"}],"component":"octoprint","cve_ids":["CVE-2022-1432"],"ecosystem":"PyPI","epss":0.01231,"exploited":false,"fixed_versions":["1.8.0"],"ghsa_id":"GHSA-h8pc-j334-jjhm","id":"tcs_01M5KFK7X8AFMXWRBD9ZFNXBR2","modified_at":"2024-10-07T21:35:05.533993Z","published_at":"2022-05-19T00:00:30Z","references":["https://osv.dev/vulnerability/GHSA-h8pc-j334-jjhm","https://nvd.nist.gov/vuln/detail/CVE-2022-1432","https://github.com/octoprint/octoprint/commit/6d259d7e6f5b0de9a1c762831537a386e53978d3","https://github.com/advisories/GHSA-h8pc-j334-jjhm","https://github.com/octoprint/octoprint","https://github.com/pypa/advisory-database/tree/main/vulns/octoprint/PYSEC-2022-201.yaml","https://huntr.dev/bounties/cb545c63-a3c1-4d57-8f06-e4593ab389bf"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-h8pc-j334-jjhm","url":"https://osv.dev/vulnerability/GHSA-h8pc-j334-jjhm"}],"summary":"Cross-site Scripting in OctoPrint"}