{"action":"Upgrade postfix-mta-sts-resolver to 0.5.1 or later.","affected":[{"fixed":"0.5.1","introduced":"0"}],"component":"postfix-mta-sts-resolver","cve_ids":["CVE-2019-16791"],"ecosystem":"PyPI","epss":0.00858,"exploited":false,"fixed_versions":["0.5.1"],"ghsa_id":"GHSA-h92m-42h4-82f6","id":"tcs_01M5KFK9EDEFV8G5XNWBM4X1EY","modified_at":"2026-09-10T03:47:52.688559963Z","published_at":"2019-07-05T21:06:58Z","references":["https://osv.dev/vulnerability/GHSA-h92m-42h4-82f6","https://github.com/Snawoot/postfix-mta-sts-resolver/security/advisories/GHSA-h92m-42h4-82f6","https://nvd.nist.gov/vuln/detail/CVE-2019-16791","https://gist.github.com/Snawoot/b9da85d6b26dea5460673b29df1adc6b","https://github.com/Snawoot/postfix-mta-sts-resolver","https://github.com/pypa/advisory-database/tree/main/vulns/postfix-mta-sts-resolver/PYSEC-2020-174.yaml"],"severity":{"label":"medium","score":6.9},"sources":[{"source":"osv","source_id":"GHSA-h92m-42h4-82f6","url":"https://osv.dev/vulnerability/GHSA-h92m-42h4-82f6"}],"summary":"postfix-mta-sts-resolver Algorithm Downgrade vulnerability"}