{"action":"Upgrade hapi to 2.2.0 or later.","affected":[{"fixed":"2.2.0","introduced":"2.0.0"}],"component":"hapi","cve_ids":["CVE-2014-3742"],"ecosystem":"npm","epss":0.02374,"exploited":false,"fixed_versions":["2.2.0"],"ghsa_id":"GHSA-cqr7-78pj-3g7j","id":"tcs_01M5KFKDWTZEWWKTWW8RKYBEMP","modified_at":"2023-11-08T03:57:40.985072Z","published_at":"2017-10-24T18:33:36Z","references":["https://osv.dev/vulnerability/GHSA-cqr7-78pj-3g7j","https://nvd.nist.gov/vuln/detail/CVE-2014-3742","https://github.com/spumko/hapi/issues/1427","https://github.com/advisories/GHSA-cqr7-78pj-3g7j","https://github.com/spumko/hapi","https://www.npmjs.com/advisories/11","http://www.openwall.com/lists/oss-security/2014/05/13/1","http://www.openwall.com/lists/oss-security/2014/05/15/2"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-cqr7-78pj-3g7j","url":"https://osv.dev/vulnerability/GHSA-cqr7-78pj-3g7j"}],"summary":"File Descriptor Leak Can Cause DoS Vulnerability in hapi"}