{"action":"Upgrade vllm to 0.8.4 or later.","affected":[{"fixed":"0.8.4","introduced":"0.6.5"}],"component":"vllm","cve_ids":[],"ecosystem":"PyPI","exploited":false,"fixed_versions":["0.8.4"],"ghsa_id":"GHSA-hf3c-wxg2-49q9","id":"tcs_01M5KFKFVAH085ERK5TY4SXWGH","modified_at":"2025-04-15T21:21:04Z","published_at":"2025-04-15T21:21:04Z","references":["https://osv.dev/vulnerability/GHSA-hf3c-wxg2-49q9","https://github.com/mlc-ai/xgrammar/security/advisories/GHSA-389x-67px-mjg3","https://github.com/vllm-project/vllm/security/advisories/GHSA-hf3c-wxg2-49q9","https://github.com/vllm-project/vllm/pull/16283","https://github.com/vllm-project/vllm/commit/cb84e45ac75b42ba6795145923e8eb323bb825ad","https://github.com/vllm-project/vllm"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-hf3c-wxg2-49q9","url":"https://osv.dev/vulnerability/GHSA-hf3c-wxg2-49q9"}],"summary":"vLLM vulnerable to Denial of Service by abusing xgrammar cache"}