{"action":"Upgrade antilles-tools to 1.0.1 or later.","affected":[{"fixed":"1.0.1","introduced":"0"}],"component":"antilles-tools","cve_ids":["CVE-2021-3840"],"ecosystem":"PyPI","epss":0.02036,"exploited":false,"fixed_versions":["1.0.1"],"ghsa_id":"GHSA-hgc3-hp6x-wpgx","id":"tcs_01M5KFKJY4AZS0P3QZQRTGVTTA","modified_at":"2026-07-08T06:29:27.141445075Z","published_at":"2021-11-03T17:36:22Z","references":["https://osv.dev/vulnerability/GHSA-hgc3-hp6x-wpgx","https://github.com/lenovo/Antilles/security/advisories/GHSA-hgc3-hp6x-wpgx","https://nvd.nist.gov/vuln/detail/CVE-2021-3840","https://github.com/lenovo/Antilles/commit/c7b9c5740908b343aceefe69733d9972e64df0b9","https://github.com/lenovo/Antilles","https://github.com/pypa/advisory-database/tree/main/vulns/antilles-tools/PYSEC-2021-840.yaml"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-hgc3-hp6x-wpgx","url":"https://osv.dev/vulnerability/GHSA-hgc3-hp6x-wpgx"}],"summary":"Antilles Dependency Confusion Vulnerability"}