{"action":"Upgrade vllm to 0.8.5 or later.","affected":[{"fixed":"0.8.5","introduced":"0.6.5"}],"component":"vllm","cve_ids":["CVE-2025-32444"],"ecosystem":"PyPI","epss":0.0182,"exploited":false,"fixed_versions":["0.8.5"],"ghsa_id":"GHSA-hj4w-hm2g-p6w5","id":"tcs_01M5KFKV6GDBJ6N2C0DYE84X0P","modified_at":"2026-08-07T08:11:59.849474550Z","published_at":"2025-04-29T14:52:29Z","references":["https://osv.dev/vulnerability/GHSA-hj4w-hm2g-p6w5","https://github.com/vllm-project/vllm/security/advisories/GHSA-hj4w-hm2g-p6w5","https://github.com/vllm-project/vllm/security/advisories/GHSA-x3m8-f7g5-qhm7","https://nvd.nist.gov/vuln/detail/CVE-2025-32444","https://github.com/vllm-project/vllm/commit/a5450f11c95847cf51a17207af9a3ca5ab569b2c","https://github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2025-42.yaml","https://github.com/vllm-project/vllm","https://github.com/vllm-project/vllm/blob/32b14baf8a1f7195ca09484de3008063569b43c5/vllm/distributed/kv_transfer/kv_pipe/mooncake_pipe.py#L179"],"severity":{"label":"critical","score":10},"sources":[{"source":"osv","source_id":"GHSA-hj4w-hm2g-p6w5","url":"https://osv.dev/vulnerability/GHSA-hj4w-hm2g-p6w5"}],"summary":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration"}