{"action":"Upgrade tensorflow to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow","cve_ids":["CVE-2021-29545"],"ecosystem":"PyPI","epss":0.00189,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-hmg3-c7xj-6qwm","id":"tcs_01M5KFM1SSR8PDY0YFB5T187K7","modified_at":"2026-07-08T06:29:25.060253961Z","published_at":"2021-05-21T14:23:25Z","references":["https://osv.dev/vulnerability/GHSA-hmg3-c7xj-6qwm","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-hmg3-c7xj-6qwm","https://nvd.nist.gov/vuln/detail/CVE-2021-29545","https://github.com/tensorflow/tensorflow/commit/1e922ccdf6bf46a3a52641f99fd47d54c1decd13","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-473.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-671.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-182.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-hmg3-c7xj-6qwm","url":"https://osv.dev/vulnerability/GHSA-hmg3-c7xj-6qwm"}],"summary":"Heap buffer overflow in `SparseTensorToCSRSparseMatrix`"}