{"action":"Upgrade fastapi-sso to 0.19.0 or later.","affected":[{"fixed":"0.19.0","introduced":"0"}],"component":"fastapi-sso","cve_ids":["CVE-2025-14546"],"ecosystem":"PyPI","epss":0.00359,"exploited":false,"fixed_versions":["0.19.0"],"ghsa_id":"GHSA-hp6r-r9vc-q8wx","id":"tcs_01M5KFM4KZ1K233X92Y0EYDJWZ","modified_at":"2026-09-10T03:50:31.957663246Z","published_at":"2025-12-19T06:30:27Z","references":["https://osv.dev/vulnerability/GHSA-hp6r-r9vc-q8wx","https://nvd.nist.gov/vuln/detail/CVE-2025-14546","https://github.com/tomasvotava/fastapi-sso/issues/266","https://github.com/tomasvotava/fastapi-sso/commit/6117d1a5ad498ba57d671e8a059ebe20db5abe02","https://github.com/tomasvotava/fastapi-sso","https://security.snyk.io/vuln/SNYK-PYTHON-FASTAPISSO-14386403"],"severity":{"label":"medium","score":6.3},"sources":[{"source":"osv","source_id":"GHSA-hp6r-r9vc-q8wx","url":"https://osv.dev/vulnerability/GHSA-hp6r-r9vc-q8wx"}],"summary":"FastAPI SSP is vulnerable to Cross-site Request Forgery (CSRF) through improper OAuth parameter validation"}