{"action":"Upgrade openclaw to 2026.3.28 or later.","affected":[{"fixed":"2026.3.28","introduced":"0"}],"component":"openclaw","cve_ids":["CVE-2026-41399"],"ecosystem":"npm","epss":0.00318,"exploited":false,"fixed_versions":["2026.3.28"],"ghsa_id":"GHSA-f44p-c7w9-7xr7","id":"tcs_01M5KFMDB65PNYXQRNQY1HND0T","modified_at":"2026-05-05T16:11:44.936766Z","published_at":"2026-03-31T23:54:00Z","references":["https://osv.dev/vulnerability/GHSA-f44p-c7w9-7xr7","https://github.com/openclaw/openclaw/security/advisories/GHSA-f44p-c7w9-7xr7","https://github.com/openclaw/openclaw/commit/cb5f7e201f3f86ad70e199ef850e636b4cc457ba","https://github.com/openclaw/openclaw"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-f44p-c7w9-7xr7","url":"https://osv.dev/vulnerability/GHSA-f44p-c7w9-7xr7"},{"source":"nvd","source_id":"CVE-2026-41399","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-41399"}],"summary":"OpenClaw: Gateway WebSocket Denial of Service via unbounded pre-auth upgrades"}