{"action":"Upgrade vyper to 0.3.2 or later.","affected":[{"fixed":"0.3.2","introduced":"0"}],"component":"vyper","cve_ids":["CVE-2022-24845"],"ecosystem":"PyPI","epss":0.01426,"exploited":false,"fixed_versions":["0.3.2"],"ghsa_id":"GHSA-j2x6-9323-fp7h","id":"tcs_01M5KFMVSG7YKFHV286RVDVGH2","modified_at":"2023-11-08T04:08:38.494818Z","published_at":"2022-04-22T20:24:13Z","references":["https://osv.dev/vulnerability/GHSA-j2x6-9323-fp7h","https://github.com/vyperlang/vyper/security/advisories/GHSA-j2x6-9323-fp7h","https://nvd.nist.gov/vuln/detail/CVE-2022-24845","https://github.com/vyperlang/vyper/commit/049dbdc647b2ce838fae7c188e6bb09cf16e470b","https://github.com/pypa/advisory-database/tree/main/vulns/vyper/PYSEC-2022-198.yaml","https://github.com/vyperlang/vyper"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-j2x6-9323-fp7h","url":"https://osv.dev/vulnerability/GHSA-j2x6-9323-fp7h"}],"summary":"Integer bounds error in Vyper"}