{"action":"Upgrade tensorflow-cpu to 2.7.2 or later.","affected":[{"fixed":"2.7.2","introduced":"0"},{"fixed":"2.8.1","introduced":"2.8.0"},{"fixed":"2.9.1","introduced":"2.9.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2022-35989"],"ecosystem":"PyPI","epss":0.00478,"exploited":false,"fixed_versions":["2.7.2","2.8.1","2.9.1"],"ghsa_id":"GHSA-j43h-pgmg-5hjq","id":"tcs_01M5KFN01CBHGNS69P94MDZARN","modified_at":"2026-07-13T16:42:47.357597756Z","published_at":"2022-09-16T22:28:06Z","references":["https://osv.dev/vulnerability/GHSA-j43h-pgmg-5hjq","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-j43h-pgmg-5hjq","https://nvd.nist.gov/vuln/detail/CVE-2022-35989","https://github.com/tensorflow/tensorflow/commit/32d7bd3defd134f21a4e344c8dfd40099aaf6b18","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/releases/tag/v2.10.0"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"GHSA-j43h-pgmg-5hjq#PyPI/tensorflow-cpu","url":"https://osv.dev/vulnerability/GHSA-j43h-pgmg-5hjq"}],"summary":"TensorFlow vulnerable to `CHECK` fail in `MaxPool`"}