{"action":"Upgrade tensorflow-cpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29532"],"ecosystem":"PyPI","epss":0.00198,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-j47f-4232-hvv8","id":"tcs_01M5KFN0YS2JMV8ZGJE0Q80VCG","modified_at":"2026-07-08T06:27:56.949404754Z","published_at":"2021-05-21T14:22:17Z","references":["https://osv.dev/vulnerability/GHSA-j47f-4232-hvv8","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-j47f-4232-hvv8","https://nvd.nist.gov/vuln/detail/CVE-2021-29532","https://github.com/tensorflow/tensorflow/commit/44b7f486c0143f68b56c34e2d01e146ee445134a","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-460.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-658.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-169.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-j47f-4232-hvv8#PyPI/tensorflow-cpu","url":"https://osv.dev/vulnerability/GHSA-j47f-4232-hvv8"}],"summary":"Heap out of bounds read in `RaggedCross`"}