{"action":"Upgrade fastapi-guard to 3.0.1 or later.","affected":[{"fixed":"3.0.1","introduced":"0"}],"component":"fastapi-guard","cve_ids":["CVE-2025-53539"],"ecosystem":"PyPI","epss":0.00481,"exploited":false,"fixed_versions":["3.0.1"],"ghsa_id":"GHSA-j47q-rc62-w448","id":"tcs_01M5KFN19XXAPXC89TENR7Y4K9","modified_at":"2026-07-07T17:56:52.023285837Z","published_at":"2025-07-07T23:36:39Z","references":["https://osv.dev/vulnerability/GHSA-j47q-rc62-w448","https://github.com/rennf93/fastapi-guard/security/advisories/GHSA-j47q-rc62-w448","https://nvd.nist.gov/vuln/detail/CVE-2025-53539","https://github.com/rennf93/fastapi-guard/commit/d9d50e8130b7b434cdc1b001b8cfd03a06729f7f","https://github.com/rennf93/fastapi-guard"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-j47q-rc62-w448","url":"https://osv.dev/vulnerability/GHSA-j47q-rc62-w448"},{"source":"nvd","source_id":"CVE-2025-53539","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-53539"}],"summary":"fastapi-guard is vulnerable to ReDoS through inefficient regex"}