{"action":"Upgrade werkzeug to 0.15.5 or later.","affected":[{"fixed":"0.15.5","introduced":"0"}],"component":"werkzeug","cve_ids":["CVE-2019-14322"],"ecosystem":"PyPI","epss":0.55803,"exploited":false,"fixed_versions":["0.15.5"],"ghsa_id":"GHSA-j544-7q9p-6xp8","id":"tcs_01M5KFN3Z61Y11XZT8749PVYG2","modified_at":"2026-07-07T11:56:35.016614553Z","published_at":"2022-05-24T16:51:33Z","references":["https://osv.dev/vulnerability/GHSA-j544-7q9p-6xp8","https://nvd.nist.gov/vuln/detail/CVE-2019-14322","https://github.com/pallets/werkzeug","https://palletsprojects.com/blog/werkzeug-0-15-5-released","http://packetstormsecurity.com/files/163398/Pallets-Werkzeug-0.15.4-Path-Traversal.html"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-j544-7q9p-6xp8","url":"https://osv.dev/vulnerability/GHSA-j544-7q9p-6xp8"}],"summary":"Pallets Werkzeug vulnerable to Path Traversal"}