{"action":"Upgrade next to 15.5.16 or later.","affected":[{"fixed":"15.5.16","introduced":"13.4.0"},{"fixed":"16.2.5","introduced":"16.0.0"}],"component":"next","cve_ids":["CVE-2026-44581"],"ecosystem":"npm","epss":0.00222,"exploited":false,"fixed_versions":["15.5.16","16.2.5"],"ghsa_id":"GHSA-ffhc-5mcf-pf4q","id":"tcs_01M5KFNC3T16AFAZ4AXCRANPAW","modified_at":"2026-09-10T03:51:05.447940563Z","published_at":"2026-05-11T15:57:12Z","references":["https://osv.dev/vulnerability/GHSA-ffhc-5mcf-pf4q","https://github.com/vercel/next.js/security/advisories/GHSA-ffhc-5mcf-pf4q","https://nvd.nist.gov/vuln/detail/CVE-2026-44581","https://github.com/vercel/next.js","https://github.com/vercel/next.js/releases/tag/v15.5.16","https://github.com/vercel/next.js/releases/tag/v16.2.5"],"severity":{"label":"medium","score":4.7},"sources":[{"source":"osv","source_id":"GHSA-ffhc-5mcf-pf4q","url":"https://osv.dev/vulnerability/GHSA-ffhc-5mcf-pf4q"}],"summary":"Next.js vulnerable to cross-site scripting in App Router applications using CSP nonces"}