{"action":"Upgrade github.com/mattermost/mattermost-server to 4.1.2 or later.","affected":[{"fixed":"4.1.2","introduced":"0"},{"fixed":"4.2.1","introduced":"4.2.0-rc1"},{"fixed":"4.3.0","introduced":"4.3.0-rc1"}],"component":"github.com/mattermost/mattermost-server","cve_ids":["CVE-2017-18888"],"ecosystem":"Go","epss":0.01112,"exploited":false,"fixed_versions":["4.1.2","4.2.1","4.3.0"],"ghsa_id":"GHSA-v2vm-hq26-5jv6","id":"tcs_01M5KFNEZYNZYKW97XDDC711YD","modified_at":"2025-12-15T20:26:03.683858Z","published_at":"2022-05-24T17:21:05Z","references":["https://osv.dev/vulnerability/GHSA-v2vm-hq26-5jv6","https://nvd.nist.gov/vuln/detail/CVE-2017-18888","https://github.com/mattermost/mattermost","https://mattermost.com/security-updates"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-v2vm-hq26-5jv6","url":"https://osv.dev/vulnerability/GHSA-v2vm-hq26-5jv6"}],"summary":"Mattermost Server is vulnerable to SQL Injection when executing multiple POST requests"}