{"action":"Upgrade class-validator to 0.14.0 or later.","affected":[{"fixed":"0.14.0","introduced":"0"}],"component":"class-validator","cve_ids":["CVE-2019-18413"],"ecosystem":"npm","epss":0.01987,"exploited":false,"fixed_versions":["0.14.0"],"ghsa_id":"GHSA-fj58-h2fr-3pp2","id":"tcs_01M5KFNNCFCE13SMCQ4H1TVFAB","modified_at":"2023-11-08T04:01:25.903566Z","published_at":"2021-10-12T16:35:45Z","references":["https://osv.dev/vulnerability/GHSA-fj58-h2fr-3pp2","https://nvd.nist.gov/vuln/detail/CVE-2019-18413","https://github.com/typestack/class-validator/issues/1422#issuecomment-1344635415","https://github.com/typestack/class-validator/issues/438","https://github.com/typestack/class-validator/issues/438#issuecomment-964728471","https://github.com/typestack/class-validator/pull/1798","https://github.com/typestack/class-validator","https://github.com/typestack/class-validator#passing-options"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-fj58-h2fr-3pp2","url":"https://osv.dev/vulnerability/GHSA-fj58-h2fr-3pp2"}],"summary":"SQL Injection and Cross-site Scripting in class-validator"}