{"action":"Upgrade devcert to 1.2.1 or later.","affected":[{"fixed":"1.2.1","introduced":"0"}],"component":"devcert","cve_ids":["CVE-2022-1929"],"ecosystem":"npm","epss":0.00641,"exploited":false,"fixed_versions":["1.2.1"],"ghsa_id":"GHSA-fp36-299x-pwmw","id":"tcs_01M5KFNVT3T4FGBAAEX7C0N8E7","modified_at":"2023-11-08T04:07:51.823462Z","published_at":"2022-06-03T00:01:01Z","references":["https://osv.dev/vulnerability/GHSA-fp36-299x-pwmw","https://nvd.nist.gov/vuln/detail/CVE-2022-1929","https://github.com/davewasmer/devcert/commit/b0763215f6683271d296fda98f7ef7bcd4a55977","https://github.com/davewasmer/devcert","https://research.jfrog.com/vulnerabilities/devcert-redos-xray-211352"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-fp36-299x-pwmw","url":"https://osv.dev/vulnerability/GHSA-fp36-299x-pwmw"}],"summary":"Regular expression denial of service in devcert"}