{"action":"Upgrade matrix-synapse to 1.62.0rc1 or later.","affected":[{"fixed":"1.62.0rc1","introduced":"0"}],"component":"matrix-synapse","cve_ids":["CVE-2022-31152"],"ecosystem":"PyPI","epss":0.01203,"exploited":false,"fixed_versions":["1.62.0rc1"],"ghsa_id":"GHSA-jhjh-776m-4765","id":"tcs_01M5KFNZM11A8M5ZZJF0BCRGS3","modified_at":"2024-09-30T20:38:34.736363Z","published_at":"2022-08-31T21:25:37Z","references":["https://osv.dev/vulnerability/GHSA-jhjh-776m-4765","https://github.com/matrix-org/synapse/security/advisories/GHSA-jhjh-776m-4765","https://nvd.nist.gov/vuln/detail/CVE-2022-31152","https://github.com/matrix-org/synapse/pull/13087","https://github.com/matrix-org/synapse/pull/13088","https://github.com/matrix-org/synapse/commit/d4b1c0d800eaa83c4d56a9cf17881ad362b9194b","https://github.com/matrix-org/synapse/commit/e16ea87d0f8c4c30cad36f85488eb1f647e640b0","https://github.com/matrix-org/synapse","https://github.com/matrix-org/synapse/releases/tag/v1.62.0","https://github.com/pypa/advisory-database/tree/main/vulns/matrix-synapse/PYSEC-2022-262.yaml"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-jhjh-776m-4765","url":"https://osv.dev/vulnerability/GHSA-jhjh-776m-4765"}],"summary":"Denial of service due to incorrect application of event authorization rules"}